Ads 468x60px

##EasyReadMore##

04 7月, 2015

安裝 QT4.8 遇到的一些問題

image
當初裝最新的 QT5.5 完全沒有遇到任何問題
原因是最新的已經幫你把 mingw + qtcreator 整合好了
所以完全不用設定
但因公司是用 QT4.8
所以只好也乖乖的用 4.8
我以為也是一鍵裝到好
沒想到一推問題跑出來
也是先下載
http://download.qt.io/official_releases/qt/4.8/4.8.7/
選了4.8 mingw 來安裝
qt-opensource-windows-x86-mingw482-4.8.7.exe
喔對了~~如果先裝了 qt4.87 再裝 mingw 會先叫你解安裝 Qt 4.8
所以下載 mingw 就好了
下載完安裝就遇到第一個問題
image
意思是找不到 G++
所以還要再去下載
http://www.mingw.org/wiki/Getting_Started
內文有個 mingw 的下載器
mingw-get-setup.exe
image
先去右邊勾選安裝包
PS: 圖中的 toolkit 其實是不用勾的
然後在 installation  選擇 Update Catalogue 就會開始下載
原本位置是指向 MinGW32 是錯的
然後再把 MinGW 的安裝位置給下面的視窗
image
接下來下載 qt creator
http://download.qt.io/official_releases/qtcreator/3.4/3.4.2/
在創新的 porject 時遇到
qt creator no valid kits found
因為 kits 沒有設定好
先去 Qtversion → Add…→
image
找到 Qt 4.8 安裝的位置下的 bin c中的 qmake
image
加入成功後會自動判斷 Qt 4.8.7
image
這時再去 kit 那 Add 新的 kit 名稱可取成 Qt 4.8.7
下面的的 Version 若剛才沒去 Version 那 add qmake
就只會出現 None
所以現在可以選擇 Qt 4.8.7 了
image

若遇到如下圖編譯器無法過的情況

那就是環境變數沒有加上

0 意見:

張貼留言

 
Blogger Templates