Ads 468x60px

##EasyReadMore##

14 8月, 2015

升級 easy_install、 python-pip

由於 easy_install 版本太舊
easy_install --version
0.6.10
有些安裝會不夠 smart
所以做一下更新

安裝步驟:

移除 python-setuptools
apt-get remove python-setuptools

下載新版 get-pip
wget --no-check-certificate https://raw.github.com/pypa/pip/master/contrib/get-pip.py

安裝 python-pip
python get-pip.py

安裝 setuptool,若遇到問題看註1
pip install -U setuptools

查詢 easy_install 版本,若遇到問題看註2
easy_install --version
setuptools 18.1

遇到問題:

註一:
bash: /usr/bin/pip: 沒有此一檔案或目錄
cd /usr/bin/
ln -s /usr/local/bin/pip

註二:
bash: /usr/bin/easy_install: 沒有此一檔案或目錄
pushd /usr/bin/
ln -s /usr/local/bin/easy_install

0 意見:

張貼留言

 
Blogger Templates